1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bug Reporting (SoA v0.1.4)

Discussion in 'Seed of Andromeda' started by Benjamin, Feb 24, 2014.

  1. Benjamin

    Benjamin Lead Developer

    • Dev Leader
    Post your bugs here! Feel free to make your own thread or post in this thread, whatever you wish. It is easier for me to respond to you if you make your own thread, just try not to duplicate bugs that have already been reported. Thanks!
  2. spacemarine658

    spacemarine658 Crash Landed

    • Member
    hi i just got a SOA.exe - system error

    "The program can't start because MSVCP120.dll is missing from your computer. Try reinstalling your program to fix this problem." help me please
  3. jessenic

    jessenic Web Developer

    • Dev Member
    I don't know if this is a bug or feature, but you can place multiple blocks without pressing B by dragging with left mouse button, then very quickly press right mouse button and release and press left mouse button. Also while testing this I found a block that had one face missing, but the texture appeared when I placed a torchlight block near it.

    Run the vcredist_x86.exe like the instructions tell you.

    P.S. I don't remember the tree being this big before cutting it! http://i.imgur.com/DnnpCFk.png
  4. Avigz

    Avigz Crash Landed

    • Member
    Im getting some Json errors:

    *ERROR: Could not open JSON file UI/ConfirmationOverlay.json
    *ERROR: JSON format error in UI/ConfirmationOverlay.json. Line 1 Column 1. not a value
    *ERROR: JSON object read exception in UI/ConfirmationOverlay.json. All values in this file must be encapsulated in a main object.
    ;
    And im also getting some wierd crashes, when i try to create a world? sometimes i get to play in the world for 10-12 sec and then the game crashes without any errors? i will try to run it as administrator and report back.

    -Avigz
  5. Benjamin

    Benjamin Lead Developer

    • Dev Leader
    That sounds really strange... I don't see anything wrong with the confirmation overlay. Maybe try re downloading and extracting? Dont extract over an old version. Try a brand new install and see if that works. As for the crashes, ill post a guide to installing gdebugger which should help you give detailed info.
  6. Avigz

    Avigz Crash Landed

    • Member
    [​IMG]
    This is the latest bug i get.
    I just deleted the old folder and completely re extracted the game. When i run it as administrator i get no error message, but the same crash

    I installed vcredist at the first update, and i have tried updating it since.
    My pc specs if needed:
    Cpu: i5 2500k overclocked to 4.4 ghz
    Gpu: Amd Radeon hd 7970 standard clock
  7. JM97

    JM97 Crash Landed

    • Member
    There's a very strange slide on the terrain, I'm almost sure this is not a bug, but an effect of how round planets work, but anyways, here's what happens:
    [video=youtube]http://www.youtube.com/watch?v=C0B_o3tGmdM&feature=youtu.be[/video]
    As you can see in the video, it gets worse when you are near the world corners.
  8. Sir_Moodz

    Sir_Moodz Lord of Andromeda

    • Contributor
    The Moon planet is very small, and the distortion becomes even more extreme, hopefully the distortion will be fixed in the future.
  9. Benjamin

    Benjamin Lead Developer

    • Dev Leader
    That is definitely a bug, not a product of distortion. I will fix this! I think some math may be behaving incorrectly on small planets. Thanks!
  10. KibbledToBits

    KibbledToBits Kibble

    • Member
    The music cuts out while loading the game then pops back up after a few seconds, moving to fast can cause the screen to black out, trees gained the ability to fly if you are to close or to far away, my game crashed for digging to far down and it said "Pure virtual crash," C4 hates left hands and crashs the game, resolution needs to [/align]be fixed. example (If you turn the game to Fullscreen it makes the mouse appear higher than it is, I found a way to fix it by setting it to 1280 x 720.) Land that is under water but to far to render the blocks makes it look like its not under water also trees that have a place holder spawn on this land just before the shore.

    come on Ben you can fix it :D
  11. Benjamin

    Benjamin Lead Developer

    • Dev Leader

    Thank you! Working on it :)
  12. dannsair2

    dannsair2 Crash Landed

    • Member
    no matter what I do I keep getting system error glew32.dill is missing. and I have tried reinstalling it didn't help
  13. Benjamin

    Benjamin Lead Developer

    • Dev Leader
    It sounds like you did not extract the zip file. You need winrar or some other archiver, then you need to right click on the file that you downloaded and extract it. Doing this will uncompressed all the files that are in the .zip and put them outside the folder. Then you can open this new folder and run the game.

    http://www.wikihow.com/Open-a-.Zip-File-Without-Winzip
  14. Gingy

    Gingy Back Into Space

    • Member
    That's not the error you get if you don't first run vcredist_x86.exe, is it?

    If it is, try running that. It'll be in the .zip file that the game came with.
    [hr]
    This is an issue with the way that the world is displayed. I don't think there's a solution for it yet, but it has something to do with the fact that the game is basically a giant cubic world mapped to look like a sphere.
Similar Threads: Reporting (SoA
Forum Title Date
Seed of Andromeda Bug Reporting (SoA v0.1.3) Feb 20, 2014

Share This Page