1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My Journey With Linux

Discussion in 'General Gaming' started by PsychoticLeprechaun, Oct 3, 2015.

  1. PsychoticLeprechaun

    PsychoticLeprechaun Designer & Web Developer

    • Dev Member
    So, having received and set up my new rig, I'll start off chronicling my journey with Linux and the fun I've had installing it and setting it up!

    The Great Installation

    When I first received it, the rig was without an OS (I wanted to install Ubuntu myself) and so I got started with running the installation process of Ubuntu, in UEFI mode - this is important, and something I didn't realise at the time. The process died pretty quickly at first; hitting "Install Ubuntu" lead to a black screen and nothingness. A guess on my part and a quick search based on it lead to the conclusion my set-up is too new for the Linux kernel 14.04.3 packages with to handle - this was resolved by adding a flag called "nomodeset" in the boot line for the process. Adding the nomodeset flag was trivial at this point, and so I managed to get the installation running. On a side note, I also added a flag called nolapic, which did nothing for me but no harm in running as basic a process as possible, eh?

    So I got Ubuntu installed, and I rejoiced. I then booted the machine, and to my horror it black screened again - with seemingly no opportunity to get at Grub - for those that don't know, the bootloader used by Ubuntu and the only easy opportunity to configure the boot process for Ubuntu. I tried various buttons, from the standards of Shift, F8 and Escape, to weird ones like the Super key... nada. I cried a little, and then spoke to some other people. One pointed out I could access the boot drive of the installation if I booted the livesystem that the Linux bootable USB installer offers.

    So I get into the livesystem, and start trying to fiddle with the settings of Grub in the installation proper. I then realise I have an issue: gotta run update-grub from within the installed Ubuntu system - doing it in the livesystem would succeed at nothing. So I play about with mounting the boot drive and chrooting into it and then running update-grub. Before I ran the command, I checked the boot directory to double check Grub was properly installed and found it barren. Completely and utterly barren. So I try to run the command anyway, because: "hell, why not?" I got an "error of unable to resolve host ubuntu" or something along those lines which was resolved by going into my hosts file in the installation drive and adding ubuntu as a valid 127.0.0.1 alias. Ran the command, and things looked like maybe I had fixed them. As another side note, this is almost certainly the hackiest, slashiest attempt to fix an OS boot loader ever, and I would never recommend it unless you know what you are doing at each step - I did it, but I already had a bricked system, so not exactly much more could go wrong.

    Reboot, and nada again. So at this point, I decide a reinstallation is a good strategy, so I do that. I tried to get into Grub again, this time just using shift - it's the only one that is commonly recommended so I assumed it would be right - to no luck. After some more discussion and a saviour on askubuntu reminding me of the escape key, I tried that out. To my wonder of wonders, I managed to get into Grub! It turns out that installing Ubuntu in UEFI mode changes the key used to access Grub - whhhhyyyyy?! After that it was a simple case of adding the nomodeset flag to the boot line for Ubuntu and getting my needed drivers installed so that my graphics card would work properly with Ubuntu.

    Once all of that was done, I realised I had no sound - the Z170 chipset is real new, and the kernel on 14.04.3 I guess is just a version or two too old. So I go and grab the latest stable unstable version of the Linux kernel (4.2.2) and install that - "stable unstable" because it at least isn't just a release candidate but at the same time isn't supported by Canonical (the guys that make Ubuntu). I now have sound, a functioning graphics card and a real nice responsive system!

    Come 14.04.4, if it's on a bleeding edge kernel version, I could potentially upgrade to that - I kinda want 4.3 so that Skylake's iGPU is explicitly supported.
    Last edited: Oct 3, 2015
    PsychoticLeprechaun, Oct 3, 2015
    Last edited by PsychoticLeprechaun; at Oct 3, 2015
    #1
    Gingy and joppiesaus like this.
  2. PsychoticLeprechaun

    PsychoticLeprechaun Designer & Web Developer

    • Dev Member
    Crackling Sounds of Skyrim

    So with the installed OS, I wanted to try out pushing the GPU a bit, how better than trying out Skyrim? I've not got round to trying out the PCI passthrough idea, so I have just installed Wine and PlayOnLinux to try it out. During the process, I saw some users mention issues with sound, but I thought perhaps I would get away with the set up and not have sound issues. I was wrong. Skyrim started up with basically no understandable sounds working (except for the intro Bethesda logo drum bit). Just crackling. I could barely understand the NPCs when I started a new game. So I look around online and see some recommendations that PulseAudio could be to blame. One person suggested 32-bit packages need to be installed: nope, they were installed. Another suggested changing the configuration of daemon.conf for PulseAudio. I changed a couple of values regarding fragments (default-fragments and default-fragment-size-msec) both to smaller and larger values than their default. Both actually yielded better results than the default config, and I could actually hear very specific sound channels undisturbed - weirdly one channel would play fine, while others would sound god awful (by channel I mean, i.e. the vocals in the main menu soundtrack played fine while the melody and percussion parts were both distorted by this crackling (actually I would describe the distortion on the melody more as a "noisy warp" than a crackle)).

    So the current state of the game is that I can run it, and it sounds kinda crap but not as crap as before - it's playable. So then I thought "well, I really want to be playing modded Skyrim", so I went to PlayOnLinux and installed another Wine machine that runs Mod Organizer (I have yet to figure out how to install multiple programs in the same Wine VD). It has linked up with the Skyrim install fine (exploiting the Z drive in Wine), but I have yet to test if I can boot Skyrim from Mod Organizer - I suppose some fiddling would let me.

    My hopes with this are to get modding working, and find some method to benchmark FPS. I know it won't perform phenomenally, but it doesn't have to. My next major job on the OS is to try out the PCI passthrough and then if that fails or is impractical, I'll install Windows in a dual-boot config.
    Last edited: Oct 3, 2015
    PsychoticLeprechaun, Oct 3, 2015
    Last edited by PsychoticLeprechaun; at Oct 3, 2015
    #2
    joppiesaus likes this.
  3. Sevio

    Sevio Back Into Space

    • Member
    As it happens I've been handed a pet project at work involving setting up a new server as a Xen host that I will be looking into in the coming weeks, funny coincidence. :) The server probably won't have any use for PCI passthrough but since I will be diving into setting up Xen I might as well read up a bit on it anyway, should be interesting!

    If you can get it to work, that should be the definitive end to all gaming woes as you'll then be able to run it in a Windows VM with full compatibility and practically native performance. :)
    Sevio, Oct 6, 2015
    Last edited by Sevio; at Oct 6, 2015
    #3
    PsychoticLeprechaun likes this.
  4. PsychoticLeprechaun

    PsychoticLeprechaun Designer & Web Developer

    • Dev Member
    Yup, I have the next chapter to write up in my grand journey, but need to wait till I have enough free time to get it written.
  5. Gingy

    Gingy Back Into Space

    • Member
    I guess I shouldn't complain about the problems I've had with Linux so far, because it installed fine out of the box, and I didn't have any major issues with Pulseaudio. I did have an issue with the font when trying to run Steam in WINE, but that was easily fixed by downloading system fonts. Unfortunately, the game runs like ass, because I'm constrained to a GT 610 for my GPU. Regardless, I'm looking forward to hearing how things go with PCI passthrough, as it's a relatively new concept to me (so new that I had to Google it when I got to that point in your post).
  6. TYHENDER

    TYHENDER Industrial Re-revolutionist

    Lol,never had any problem with my linux(Xubuntu 16).
    Maybe that's because of my old processor?

    EDIT--------------------------------------+

    Oh and yeah,i rarely use WINE,only VirtualBox with Game Prelauncher
    TYHENDER, Aug 26, 2016
    Last edited by TYHENDER; at Aug 26, 2016
    #6
  7. Gingy

    Gingy Back Into Space

    • Member
    That could be because 16.04 hadn't come out when this thread started. Although, I feel it's worth noting that I'd recommend you wait for the x.x.1 release when the next LTS version (18.04) comes around. I learned the hard way that the very first release for Ubuntu is usually way buggier than the x.x.1 version.
  8. TYHENDER

    TYHENDER Industrial Re-revolutionist

    Yes it is more buggier.
    Right now,GNU/Linux is was more bug-free,and a lot of games is now ported on Linux. Linux overcomes Windows slowly!
  9. Gingy

    Gingy Back Into Space

    • Member
    Yeah, Linux is fortunate now that 2K and Square Enix are making games for the platform. Valve is also a big player, but they've been a big player for years. The 2K and Square support is new. WINE also makes Linux more appealing, but it's not an end-all solution.
  10. TYHENDER

    TYHENDER Industrial Re-revolutionist

    I almost didn't use WINE,because i could start only Bioshock Infinite on it,no other game worked.
  11. TYHENDER

    TYHENDER Industrial Re-revolutionist

    REALLY WORKS!!!(Does not)

    I think we need more mods,or something like patrol,because those bots is more active than members.
    TYHENDER, Sep 20, 2016
    Last edited by TYHENDER; at Sep 20, 2016
    #11
Similar Threads: Journey Linux
Forum Title Date
General Gaming Favorite game on Linux Nov 2, 2014

Share This Page